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NotesWhat’s the Purpose 
of a Tag?
In a PDF file, tags identify the textual content 
within a document and establish its role in 
the document. Common tags you’ll likely 
see in a PDF are H1 (Heading Level 1), H2 
(Heading Level 2), P (Paragraph), Table, etc. 

The importance of tags becomes relevant 
when a user of Assistive Technology (AT) 
is reviewing  a document. Many of the 
tags, particularly the headings are voiced 
as the content is being reviewed.

 For example, the heading on this page would be 
voiced as “TAGS heading level 2”. The fact that the 
content is voiced as a heading is less important than 
the capability that is provided to the AT or screen 
reader user as they are reviewing  the document. 

As a sighted user, when a newspaper, magazine, 
or online article is being read, headlines are used 
to segregate the information in the article or 
document to determine what content is of interest 
or to locate specific content within the document. 

Users of AT gain this same capability by tapping 
the H key on their keyboard. Performing this 
step reads all of the headings in the document 
to help the user understand what that section 
is about, and helps them determine if they’d 
like to read more about that section. 

Generating a PDF file with no headings 
leaves your reader only two choices:  read 
the content from beginning to end with no 
way to segregate the information, or skip 
reviewing your content altogether.
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NotesHow Do I Add Tags 
to a Document?
How tags are added to a document depends 
largely on how the PDF file is created. 

If you start with an existing PDF, tags must 
be added in Acrobat or another third-party 
application. This process of adding tags to 
the PDF file is very manual, time- consuming, 
mundane, and honestly expensive. We encourage 
users to avoid this method whenever possible, 
though sometimes it’s the only option.

A more reliable and powerful approach is to utilize 
a source file or authoring tool application that 
provides the capability to include accessibility 
tags and information, which will be exported 
when a PDF file is generated. Common 
applications that provide this capability are: 

•  Microsoft Word 

•  Microsoft PowerPoint 

•  Microsoft Excel 

•  Adobe InDesign 

One of the key benefits of leveraging the 
authoring tool applications when creating an 
accessible PDF is that any accessibility attributes 
you apply in the source file are repeatable. If 
changes are needed, you can simply re-export 
the PDF, and all of the attributes will be included 
in the new file, saving a lot of rework. 

Imagine you had remediated a PDF directly, 
only to have new edits or a replacement 
file arrive—you’d be forced to redo all 
of that work from the beginning.
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Metadata properties can be added in 
Word by choosing File > Info. 

Microsoft Word
Microsoft Word is a good choice for creating 
accessible PDF files. This is because of the popularity 
of this  authoring application and also because Word 
provides a number of tools that can be leveraged 
in facilitating the creation of an accessible PDF file. 

Because Word contains a natural top-to-bottom 
flow, it’s easy to define the tag order, provided 
you leverage that natural flow. Inserting elements 
such as text boxes can cause order issues when 
exporting to the PDF format from Word. 

Adding a Document Title 
All accessible PDF files need a document title 
and that title needs to be displayed when the 
PDF file is opened in a PDF reader such as Adobe 
Acrobat Pro or Adobe Acrobat Reader. Word 
gives us the ability to add a title that will be 
included when creating an accessible PDF file. 

To add a title in Word, choose File > Info. In the 
Properties category on the right side of the 
screen, you’ll see an area where you can enter an 
appropriate document title. Although the title is the 
only required metadata element for accessibility, 
because these documents will likely be published 
online, it can be beneficial to add other metadata 
that will carry over to the PDF file, including: 

•  Title

•  Subject 

•  Author

•  Company

•  Tags (Keywords) 

Word defines the logged in user of the person 
creating the document as the author. This 
typically doesn’t make sense for a published 
document. You can right-click on an existing 
author and choose “remove person” and 
then type in a new author in its place.
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NotesDefining Tags

Default Styles in Word
In order for content to output as the appropriate 
tag in an exported PDF file, it’s imperative that 
styles are used to format text in a Word document. 
The easiest way to apply heading tags to text 
in a PDF is to use the default heading styles in 
Word. Those default heading styles are named: 

•  Heading 1 

•  Heading 2 

•  Heading 3 

•  Heading 4 

•  Heading 5 

•  Heading 6 

Although Word contains more than six 
heading levels, only headings 1 through 
6 will map to tags in a PDF file. 

Some Word users are put off by the appearance 
of these default headings. It’s important to 
remember that you can modify or edit the font, 
size, color, style, and more of these styles easily 
by changing the appearance of the text to your 
desired appearance and then clicking to the right 
of the style name in the Styles pane and choosing 
“Update [style name] to match selection.”

Creating, using, and distributing a default Word 
template for yourself or your organization 
with heading styles and appearances that 
align with your brand and/or desired display 
preferences will reduce the number of times 
you may need to manually adjust the default 
heading styles within your Word documents. 
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Notes

Defining the outline level in a Microsoft Word style. 

Custom Styles in Word 
Sometimes you may choose to create your own new 
styles instead of using or editing one of the default 
styles in Word. This is a fine approach; however if 
that style is to serve as a heading at any level, it 
will not work by default as user-created styles will 
always map to a <P> tag in an  exported PDF. In 
order to get a user-created style to map to any tag 
other than a <P> tag, special care must be taken. 

To control what tag the user-created style will 
map to, click on the triangle to the right of 
the name of the style in the Styles pane, and 
choose Modify. In the Modify Style dialog box, 
click on the Format drop-down menu in the 
lower-left corner of the dialog box and choose 
Paragraph. In the Paragraph dialog box, you’ll 
see an Outline level drop-down menu. 

The default outline level is Body Text, 
which maps to a <P> tag in the exported 
PDF file, while Level 1, Level 2, etc., map to 
the equivalent heading tag in a PDF. 
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Heading styles in Word appear in the Navigation 
pane for easy structure analysis.

Notes

Bulleted and Numbered Lists 
When creating lists in Word, it’s important to 
leverage the bulleted or numbered list formatting 
buttons located in the Home tab of the ribbon. 
Using these buttons will automatically apply 
bullets or numbers to selected text, and also 
ensure that they will be tagged as a list in the 
exported PDF. Lists can be customized in Word to 
use items other than a standard bullet or to use 
letters, roman numerals, etc. for numbered lists. 

However, when doing so, please keep in mind that 
very often screen readers vocalize icons, symbols, 
emojis, and more much differently than you may 
anticipate. Testing your PDF document’s bullet-
pointed lists with a screen reader will ensure a much 
smoother listening experience for your readers.

Navigation Benefits 
A side-benefit of using the default heading styles in 
Word and customizing styles to use outline levels, 
is that the Navigation pane in Word populates 
with the text that has those styles applied. 

The benefit of the Navigation pane is that it makes it 
easy to see how headings are applied in a document 
and how the document is structured. In addition, 
the Navigation pane can be used to quickly and 
easily navigate throughout the document by 
clicking on an item within the Navigation pane. 
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Choose PDF from the Format drop-down menu. 

Defining the accessibility properties in the Options dialog box.

Creating PDFs

Microsoft Method
Depending on your setup, Word provides at least 
two methods to create an accessible PDF file. 
The first method is achieved by choosing File > 
Save As or File > Save A Copy and choosing PDF 
from the format drop-down menu. To define the 
accessibility properties of the PDF, click on the More 
options link below the format drop-down menu. 

Now click on the Options button at the bottom of 
the dialog box. In the Options dialog box, make 
sure that the following options are chosen: 

•  Create bookmarks using headings 

•  Document properties 

•  Document structure tags for accessibility. 

These three options do a lot, including adding the 
document metadata from Word to the PDF. Adding 
tags to the PDF, and adding bookmarks in the PDF 
file based on the heading styles used. With these 
properties set, click OK and save the PDF file. The 
resulting PDF will be tagged, contain bookmarks, 
and include the metadata added from Word. 

As an aside, bookmarks are required for documents 
containing 9 or more pages. Including bookmarks 
in the PDF file satisfies this requirement.
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The Acrobat tab in Microsoft Word indicating 
that the PDFMaker has been installed. 

Setting the appropriate accessibility options 
in the Acrobat PDF Maker dialog box.

Adobe Method 
If you have Adobe Acrobat Pro installed, the 
installer will add a component to Microsoft Office 
applications on your computer (including Word) 
called the PDFMaker. This is an Adobe plug-in 
that adds the capability to create accessible PDFs 
from Microsoft products. If PDFMaker is installed, 
you’ll see an Acrobat tab above the Ribbon. 

Click on the Acrobat tab, then click on the 
Preferences button to control the properties 
of how the PDF file will be generated. 

In the Acrobat PDFMaker dialog box, make 
sure that the following options are enabled: 

•  Convert Document Information 

•  Create Bookmarks 

•  Add Links 

•  Enable Accessibility and Reflow  
with Tagged PDF 

Enabling these options will ensure that you 
create a tagged PDF with all of the necessary 
accessibility elements. Notice that this is 
where you control whether bookmarks will 
be created in the exported PDF file. 

Note: We don’t recommend using Word’s Create 
PDF option, as it can cause tagging errors or 
loss. Instead, use File > Save As > PDF, which 
preserves structure and reduces cleanup.
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Notes

Enabling header rows for a table in Microsoft Word 

Tables 
Although Word does a pretty good job of adding 
header rows to a table, the feature isn’t complete. 
For accessibility, header rows need to have cell 
IDs created to associate data and header cells 
(for complex tables) or defined scope  for the 
header cells (column, row, or both). Since Word 
does neither, additional touch-up in Acrobat 
is always required after exporting to PDF.

One area where Word fails significantly is when cells 
are merged in a table. Merged cells don’t export well 
to PDF and will always need additional remediation 
in Acrobat after the PDF file is generated. 
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NotesHyperlinks 
Hyperlinks are an important part of a PDF file as 
they provide a quick and efficient way to obtain 
additional information on the web and other 
locations. Acrobat auto-detects implicit hyperlinks 
(any spelled-out URL or email address) and makes 
that link clickable within the application. 

It gives the illusion that all of those links are 
both clickable and accessible, but that is not 
the case. It’s important to properly create 
hyperlinks in Word so that those links are 
properly tagged and accessible to users of AT. 

To create a hyperlink in Word, select the text 
that you want to add a link to. Then right-
click on the selected text and choose Link. 

The Insert Hyperlink dialog box will appear 
providing you with several options for the type of 
link you want to create. You can create the following 
types of links in the Insert Hyperlink dialog box: 

•  Link to an existing file or web page 

•  Link to a location in the document 

•  Link to an email address 

Choose the type of link that you want to create 
and then enter the destination url (if appropriate). 
Click OK and the link will be created. 

The importance of performing this step is that 
now when the PDF file is generated, that link 
will contain a <Link> tag with a Link-OBJR 
object within that tag making that hyperlink 
accessible to users of assistive software. 
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Notes

Creating a hyperlink in Microsoft Word. 

Screen tips 
When trying to meet PDF/UA compliance, an 
additional requirement for hyperlinks is that each 
hyperlink contains alternative text. This may seem 
like overkill, but it stems from a time when it was 
common to use phrases such as “click here” for a 
hyperlink which isn’t very descriptive and doesn’t 
tell a reader where the link is taking them. 

Word allows you to add alternative text to 
hyperlinks by clicking on the ScreenTip button 
at the top right of the Insert Hyperlink dialog 
box. Here you can add descriptive text that 
will satisfy the alt-text requirement.
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Inserting a Table of Contents in Microsoft Word. 

NotesCreating a Table of Contents
A table of contents can be a significant benefit 
to both sighted users and users of AT, if done 
properly and accessibly. The key to generating 
an accessible table of contents is to simply 
leverage the table of contents feature in Word. 

By using this feature, the table of contents in 
the exported PDF file will create links for all of 
the table of contents entries that will link to 
the appropriate section of the document.

In addition, the table of contents in the exported 
PDF file will be properly tagged. Word generates 
a table of contents based on the heading styles 
used in the document. Each heading becomes an 
entry in the table of contents when it is created. 

To create a table of contents in Word, start by 
inserting your cursor in the document where 
you would like the table of contents to appear. 
Click on the References tab at the top of the 
Ribbon and click the Table of Contents button. 
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Notes

Updating a Table of Contents in Microsoft Word. 

Word is pretty intelligent here as it will automatically 
generate some Automatic Tables of Contents 
form which you can choose. There’s also an option 
at the bottom of the list called Custom Table 
of Contents that you can choose if you want to 
customize the table of contents to your liking. 

For this example, let’s choose an Automatic 
Table of Contents and you’ll see that the table 
of contents is inserted at your cursor location. 

A table of contents in Word is dynamic which 
means it maintains an association to the data 
that is generating the entries in the table of 
contents. So as you’re working, if you decide 
to add, remove, or adjust any of the content 

in the document, you can simply update the 
table of contents with the new information. To 
update a table of contents in Word, click anywhere 
within the table of contents, and click the update 
badge at the top of the table of contents. 

In the resulting Update Table of Contents dialog 
box, you can choose whether to update the 
entire table of contents or the page numbers 
only. Choosing either option and clicking OK will 
update the table of contents appropriately.
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Adding alternate text for an image in the 
Alt Text pane in Microsoft Word.

Working with Images 
Images require special attention when it comes to 
accessibility because fundamentally images contain 
no relevant information. Assistive software will 
voice an image as “graphic” but beyond that there’s 
no information about the image that can be read. 

That’s where alternate text comes into play. 
Alternate text or alt text is text that describes 
an image in its context. The job of alt text is to 
describe  what you are seeing in an image.

For more information on writing good 
alternate text, read this article from WebAIM 
that discusses the topic in more detail. 

Conversely, sometimes images are used in a 
document strictly for aesthetic reasons. They’re 
used to add visual interest in a document 
but they really don’t have much value in the 
context of the content of the document. 

For these images, a common practice is to artifact 
them. Artifacting is a term used to describe images 
that should not be read by assistive software. 
When an image is artifacted, assistive software 
ignores it as if it weren’t in the document at all. 

To add alternate text to an image in Word, click 
on the image to select it, then right click on the 
selected image and choose Edit Alt Text. The alt 
text pane will appear containing a field in which 
you can type the alt text for the selected image. 

If you’re using a recent version of Word, you 
may also notice a check box at the bottom of 
the Alt Text pane called “Mark as decorative”. 
This check box will artifact the image so 
it is not read by assistive software.
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NotesTag Order 
The order of tags in a PDF is critical because assistive 
technologies like JAWS and NVDA read the content 
in the same order shown in the tags pane of Acrobat.

If care is not taken to ensure that the tag order 
is correct, the experience to the end user 
could be confusing and not make sense. 

Reading Order 
PDF documents contain an additional order of 
objects beyond the Tag Order which is referred 
to as the Reading Order. The Reading Order is 
visible in Acrobat when the Reading Order tool is 
activated or when the Order panel is activated. As 
stated before, although JAWS and NVDA utilize 
the tag order to determine the order in which 
content is read, some assistive technologies use 
the Reading Order instead. So to ensure that all 
technologies can read an accessible PDF file that 
you generate, and to meet WCAG success criteria 
1.3.2, both orders need to be properly defined in 
an accessible PDF file to ensure that the document 
can be read by all users and all technologies.
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Accessibility is a Journey
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Your Learning
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upcoming courses.

Or visit 7je2.short.gy/courses

https://7je2.short.gy/courses


solutions@chaxtc.com | Follow us youtube facebook-square linkedin

Chaxtc.com

https://www.linkedin.com/company/chax-training-and-consulting

	What’s the Purpose of a Tag?
	How Do I Add Tags to a Document?
	Microsoft Word
	Adding a Document Title 

	Defining Tags
	Default Styles in Word
	Custom Styles in Word 
	Bulleted and Numbered Lists 
	Navigation Benefits 


	Creating PDFs
	Microsoft Method
	Adobe Method 
	Tables 
	Hyperlinks 
	Screen tips 
	Creating a Table of Contents
	Working with Images 
	Tag Order 
	Reading Order 



	What's the Purpose of a Tag?: 
	How Do I Add Tags to a Document?: 
	Defining Tags: 
	Custom Styles: 
	Bulleted and Numbered Lists: 
	Tables: 
	Hyperlinks: 
	Screen Tips: 
	Table of Contents 1: 
	Table of Contents 2: 
	Tag and Reading Order: 


